23
General utilities library
[utilities]
23.11
Smart pointers
[smartptr]
23.11.2
Shared-ownership pointers
[util.smartptr]
23.11.2.2
Class template
shared_ptr
[util.smartptr.shared]
23.11.2.2.8
shared_ptr
specialized algorithms
[util.smartptr.shared.spec]
template<class T> void swap(shared_ptr<T>& a, shared_ptr<T>& b) noexcept;
1
#
Effects:
Equivalent to
a.swap(b)
.