23
General utilities library
[utilities]
23.11
Smart pointers
[smartptr]
23.11.2
Shared-ownership pointers
[util.smartptr]
23.11.2.3
Class template
weak_ptr
[util.smartptr.weak]
23.11.2.3.6
weak_ptr
specialized algorithms
[util.smartptr.weak.spec]
template<class T> void swap(weak_ptr<T>& a, weak_ptr<T>& b) noexcept;
1
#
Effects:
Equivalent to
a.swap(b)
.